mibuso.com

Microsoft Business Solutions online community
It is currently Wed Oct 01, 2014 6:15 pm

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: RDLC report producing different results than classic
PostPosted: Fri Apr 19, 2013 5:04 pm 
Offline

Joined: Wed Aug 15, 2012 1:45 pm
Posts: 18
Country: United States (us)
Hi all. I've produced a small mod that displays 2 UOM for Qty (optionally) and Unit Price (always). In classic it works perfectly. However, I get strange results when it is produced in RTC. I've seen code before with ISSERVICETEIR so apparently the results can be different but I've never understood why. In any case, I call a function from the SalesLineTemp in a blanket order or the PurchaseLineTemp of a PO (base reports) but it doesn't produce correct results in classic. My code for the PO is below although similar code in all the reports I've changed fail to produce the correct result in RTC in all instances.


GetAltUOMQtyPrice(PurchLine : Record "Purchase Line")

WITH PurchLine DO BEGIN
CLEAR(MFQty);
CLEAR(MFPrice);

IF Type <> Type::Item THEN
EXIT;

MFUnitPriceHeader := 'Unit Price MSF/MLF';
ItemUOM.SETRANGE("Item No.","No.");
ItemUOM.SETFILTER(Code,'%1|%2',InventorySetup."MSF Item UOM Code",InventorySetup."MLF Item UOM Code");
IF ItemUOM.FINDSET(FALSE) THEN BEGIN
ItemUOM.TESTFIELD("Qty. per Unit of Measure");
MFQty := Quantity / ItemUOM."Qty. per Unit of Measure";
MFPrice := ROUND(AmountExclInvDisc / MFQty,0.00001);
END;
END;


Top
 Profile E-mail  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: Exabot [Bot], Google [Bot] and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum


Search for:
Jump to: